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Overview 
The EMu Multimedia repository stores and manages a wide range of document 
types. These may be: 

• In electronic format (e.g. images, Word documents, video, etc.). 
• URLs identifying a resource on the World Wide Web. 
• An identifier used to locate a particular resource (e.g. the ISBN for a book, or the 

location of a slide in the slide library). 

Each record in the Multimedia repository describes exactly one resource. Data 
describing the resource may be added to the record, allowing quite detailed 
information to be associated with it (as a minimum, the full set of Dublin Core fields is 
available). 

An issue arises when there's a need to store resources associated with a Multimedia 
record. For example, let's say a Multimedia resource is an image of a page 
containing text. Along with the image it may be desirable to have a text document 
that contains the words in the image so that users may view the image of the text but 
also have the option of reading the text in the associated document. 

Prior to EMu 4.1 there was only one way to implement such a solution:  

1. Each associated resource required its own Multimedia record.  
2. A relationship was then established between the master resource and the 

associated resources via either a text field in the Multimedia record or via an 
over-arching record in another module that links the resources (typically the 
Narratives module). 

In some cases the setting up of such structures is overkill. In the example above, the 
text document containing the words in the image may not be important enough to 
warrant its own Multimedia record. 

Other examples: 

• The master resource is an image and a cropped thumbnail is required to display 
on the web.  
The Multimedia repository generates images of various resolutions when an 
image is added but each of these resolutions is an exact copy of the master. In 
some instances it may be desirable to have cropped versions of the master, or 
even a different image completely. 
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• The master resource is a video. There may also be a separate audio track 
describing the video and an image of the first frame of the video.  
Rather than creating separate Multimedia records for the audio and image 
resources it may be more appropriate to store them with the master video itself. 

The purpose of supplementary media is to allow associated resources to be stored 
with a master resource in the same Multimedia record. Supplementary media does 
not replace the use of over-arching records to related multimedia where each 
resource is important in its own right, rather it provides a mechanism for storing other 
media with the master resource that may be used along with the master resource. 

In order to provide support for supplementary media, a Supplementary tab has been 
added to the Multimedia module. The tab is similar to the Resolutions tab and allows 
media to be added, deleted, modified, viewed and saved. The Multimedia drop-down 
menu available in each module has been extended to allow supplementary media to 
be viewed and saved. It is also possible: 

• To import supplementary media using the EMu Import facility (page 27). 
• To use supplementary media in reports (page 29). 

IMu has been extended to allow supplementary data to be accessed (page 35). 
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Supplementary tab 
All management of supplementary media is performed via the Supplementary tab in 
the Multimedia module. The bottom half of the tab consists of a Supplementary table 
that lists all supplementary media. The set of fields above the table display data 
about the media currently selected in the Supplementary table: 

 
The following fields are available: 
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Field Name Description 

Identifier The file name given to the media on the EMu server.  
This must be provided and must be unique in the Supplementary table for 
the current record. When adding new media the name of the file being 
imported is used as the default identifier. An identifier may consist of any 
characters, including spaces, except for:  
\ / : * ? " < > | 

Width (pixels) If the supplementary media is an image, the width in pixels is calculated 
automatically and stored. For other types of media that have a width in 
pixels (e.g. video) the value may be entered manually. 

Height (pixels) If the supplementary media is an image, the height in pixels is calculated 
automatically and stored. For other types of media that have a height in 
pixels (e.g. video) the value may be entered manually. 

MIME Type The type of the supplementary media.  
EMu calculates the MIME Type automatically and adds the value to this 
field. The MIME Type is a high level term describing the overall category 
into which the media belongs. Example values are: image, video, audio, 
application, etc.  
MIME Types available in EMu are defined by RFC 2046. 

MIME Format The format used to store the supplementary media.  
The value is used to determine how the media should be decoded for 
viewing, playing, etc. For each MIME Type there is a wide range of 
available formats. As with the MIME Type, EMu calculates the MIME 
Format automatically and adds the value to this field. 

MD5 Checksum A calculated value used to determine whether the media has been 
modified. 
EMu calculates the checksum automatically and adds it to this field. The 
checksum should be used where the authenticity of the supplementary 
media needs to be verified. 

File Size (bytes) The size of the supplementary file in bytes.  
EMu calculates the size of the media automatically and adds the value to 
this field. The value may be used to determine download times, storage 
requirements, etc. 

Usage A list of values outlining what the supplementary media may be used for.  
The usage field allows supplementary media to be searched for based on 
its purpose. For example, the IMu server may be queried to determine 
whether a given resource has a preferred thumbnail, which is a cropped 
version of the original image. In this case the Usage field may contain the 
term Thumbnail. A Look-up List is provided to allow some vocabulary 
control over the available values. 

Notes An area where notes about the supplementary media may be stored. The 
notes may describe what the media contains, or it may be information that 
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Field Name Description 

is displayed along with the media when displayed on a website (e.g. 
copyright information, a credit line, a textual label). 

Only the Usage, Notes, Width and Height fields may be altered. All other fields are 
calculated by EMu automatically and cannot be modified. 
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Supplementary media functionality 
The Supplementary tab provides a rich set of functions allowing media to be: 

• Added (page 9) 
• Imported (page 12) 
• Deleted (page 15) 
• Edited (page 16) 
• Viewed (page 19) 
• Saved (page 22) 
• Updated (page 24) 
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Permissions 
In order to manipulate supplementary data, users require permission to alter the 
Supplementary_tab column. They also require certain multimedia operations 
depending on the command to be performed and must be able to modify the 
Multimedia record with appropriate record level permissions. The table below 
outlines the permissions required for each of the supplementary functions available: 

 

Function Column Permissions Record 
Permissions 

Multimedia 
Permissions 

Add dvInsert, duInsert, dvEdit, duEdit Edit Add 

Import dvInsert, duInsert, dvEdit, duEdit Edit Add 

Delete dvEdit, duEdit Edit Delete 

Edit dvEdit, duEdit Edit Add 

View dvDisplay Display  

Save dvDisplay Display  

Update dvEdit, duEdit Edit Update 

Note: 

• Column Permissions are controlled via the Column Access Registry entry.  
• Record Permissions are based on record level security settings.  
• The Security Registry entry may be used to set the default permissions.  
• The record level permissions on an individual record may be altered by users 

with sufficient privileges.  
• Multimedia permissions are determined by the Multimedia|Operations 

Registry entry. 

 See the EMu Help for details. 
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How to add supplementary media 
One way to add supplementary media to a record is to take a copy of the master 
resource and modify it in an editor. When the modified image is saved, EMu asks 
whether it should be added as supplementary media. An affirmative response allows 
an identifier to be specified, after which the media is appended to the Supplementary 
table.  

 In order to add supplementary media in this way the Multimedia record must 
have a master resource available in electronic form. 

In the Multimedia module: 

1. Locate the record to which supplementary media is to be added. 
2. Select the Supplementary tab: 

 
3. Select Multimedia>Add>Supplementary in the Menu bar 

-OR- 

Select Add Supplementary  from the Toolbar beside the Supplementary 
table 
-OR- 
Use the keyboard shortcut, ALT+M+A+S. 
The master resource displays inside the editor associated with the resource type 
(in this example, the Paint application is associated with jpg images): 
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4. Modify the resource and save the image. 
5. Either exit the editor or switch back to EMu. 

The Add Supplementary dialog box displays: 

 
6. Accept or edit the Identifier to use for the supplementary resource. 

The Identifier is the file name under which the supplementary media is stored on 
the EMu server. 

7. Select . 
The new media is appended to the Supplementary table. 
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8. Add any Usage and Notes data and save the record: 
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How to import supplementary media 
If the supplementary media already exists as an electronic file outside of EMu, it can 
be imported into the Supplementary table. The process is very similar to adding a 
master resource to a Multimedia record. 

In the Multimedia module: 

1. Locate the record into which supplementary media is to be imported. 
2. Select the Supplementary tab: 

 
3. Select Multimedia>Add>File in the Menu bar 

-OR- 

Select Import Supplementary  from the Toolbar beside the Supplementary 
table 
-OR- 
Use the keyboard shortcut, ALT+M+A+F. 
The Open dialog box displays. 
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4. Locate and select the media file to be imported: 

 

5. Click . 
The Add Supplementary dialog box displays. 

6. Enter the Identifier to use for the resource. 
The Identifier is the file name under which the supplementary media is stored on 
the EMu server: 

 

7. Select . 
The file is imported and appended to the Supplementary table: 
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8. Add any Usage and Notes data and save the record. 
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How to delete supplementary media 
Supplementary media may be removed from the Supplementary table. When the 
Multimedia record is saved, any media removed will be deleted from the EMu server 
permanently. 

In the Multimedia module: 

1. Locate the record with the supplementary media to be deleted. 
2. On the Supplementary tab, click the row in the Supplementary table to be 

deleted: 

 
3. Select Multimedia>Delete Resource in the Menu bar 

-OR- 

Select Delete Supplementary  from the Toolbar beside the Supplementary 
table 
-OR- 
Use the keyboard shortcut, ALT+M+D. 
The selected media is removed from the Supplementary table. 

4. Save the record. 
The media is removed from the EMu server. 
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How to edit supplementary media 
In the Multimedia module: 

1. Locate the record with the supplementary media to be edited. 
2. On the Supplementary tab, click the row in the Supplementary table for the 

media to be edited: 

 
3. Select Multimedia>Edit Resource in the Menu bar 

-OR- 

Select Edit Supplementary  from the Toolbar beside the Supplementary 
table 
-OR- 
Use the keyboard shortcut, ALT+M+E. 
The selected supplementary resource displays inside the editor associated with 
the resource type (in this example, the Paint application is associated with jpg 
images): 
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4. Modify the resource and save the image. 
5. Close the editor and switch back to EMu. 

A dialog box requesting confirmation of the changes displays: 

 

6. Select . 
The media details are updated in the Supplementary table: 
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7. Save the record. 

The modified media is saved to the EMu server. 
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How to view supplementary media 
Supplementary media can be viewed using external applications. 

In the Multimedia module: 

1. Locate the record with supplementary media to be viewed. 
2. On the Supplementary tab, click the row in the Supplementary table with the 

media to be viewed: 

 

3. Select View Supplementary  from the Toolbar beside the Supplementary 
table 
-OR- 
Select Multimedia>Launch Viewer>Supplementary in the Menu bar and select 
the supplementary resource to view: 
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The selected supplementary resource displays inside the viewer associated with 
the resource type (in this example, the Windows Picture and Fax Viewer is 
associated with jpg images): 
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How to save supplementary media 
Supplementary media in the Supplementary table may be saved to an external 
location. 

In the Multimedia module: 

1. Locate the record with the supplementary media to be saved. 
2. On the Supplementary tab, click the row in the Supplementary table with the 

media to be saved: 

 

3. Select  from the Toolbar beside the Supplementary table 
-OR- 
Select Multimedia>Save>Supplementary in the Menu bar and select the 
supplementary resource to save: 
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The Save Multimedia dialog box displays. 

4. Navigate to the location where the file is to be saved: 

 

5. Select . 
The media is saved to the specified file. 
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How to update supplementary media 

Single record 
Many of the attributes (e.g. MIME Type, Checksum, etc.) for supplementary media 
are calculated automatically. As new media is added, the Supplementary Attributes 
fields on the Supplementary tab are maintained by EMu.  

While it is possible to batch load supplementary media to the EMu server, the 
calculated values are not computed. The Update command recalculates all 
computed values for all media in the current record's Supplementary table. 

In the Multimedia module: 

1. Locate the record with supplementary media to be updated. 
2. Select the Supplementary tab. 
3. Select Multimedia>Update Resource>Current Record in the Menu bar 

-OR- 
Use the keyboard shortcut, ALT+M+U+C. 
The Updating Multimedia dialog box displays: 

 
4. Save the record once the update is complete. 
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Selected records 
The computed values for supplementary media may also be updated for a batch of 
records. This version of the command is useful after a large import of supplementary 
media has occurred via the EMu server (that is, not imported via the EMu client). 

In the Multimedia module: 

1. Locate the records with supplementary media to be updated. 
2. Select View>List in the Menu bar 

-OR- 

Select View List  in the Toolbar 
-OR- 
Use the keyboard shortcut, ALT+V+I. 

3. Select the records to be updated. 

 See Selecting Records in the EMu help for more details. 

4. Select Multimedia>Update Resource>Selected Records in the Menu bar 
-OR- 
Use the keyboard shortcut, ALT+M+U+S. 
The Updating Multimedia dialog box displays: 
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5. Select  once the update is complete. 
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Importing supplementary media 
The EMu Import tool can be used to import supplementary media files and data into 
Multimedia records. The mechanism used is the same as for importing multimedia, 
except that the virtual column Supplementary_tab is used to contain the path of the 
media to be loaded.  

The example import file below adds supplementary media to the Supplementary 
table of existing Multimedia records (identified by their IRN): 

IRN Supplementary_tab(+) 

1324 E:\Media\Image Text.txt 
54765 E:\Media\Cropped Thumbnail.jpg 
945632 E:\Media\Audio for 945632.mp3 

EMu calculates all the computed values and loads them into the appropriate fields as 
the media is loaded. The identifier assigned to the supplementary media is the file 
name (without the path) of the imported media. 
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Multimedia and supplementary media may be loaded in the same import file, as the following import file demonstrates: 
 

MulTitle Multimedia Supplementary_tab(1) Supplementary_tab(2) 

A close-up of a bee. E:\Media\Bee\Bee.tif E:\Media\Bee\Antenna.tif E:\Media\Bee\Eyes.tif 
An 18th century arm chair. E:\Media\Chair\Arm Chair.tif E:\Media\Chair\Specification

s.doc 
 

The Canonball Express (Casey 
Jones). 

E:\Media\Casey 
Jones\Canonball Express.avi 

E:\Media\Casey Jones\First 
Frame.jpg 

 

It is also possible to import Usage and Notes values along with the media, as the following import file demonstrates: 
 

IRN Supplementary_tab(+, 
group=‘import’) 

SupUsage_nesttab(+, 
group=‘import’:1) 

SupUsage_nesttab(+, 
group=‘import’:2) 

SupNotes0(+, group=‘import’) 

1324 E:\Media\Image Text.txt Web Text  The text in the document 
contains an English 
translation of the audio 
track in the video. 

54765 E:\Media\Cropped 
Thumbnail.jpg 

Web Thumbnail Cropped A cropped thumbnail of the 
master image showing the 
spear head only. 

945632 E:\Media\Audio for 
945632.mp3 

Web Audio  An audio description of the 
objects found inside the 
painting. 

Notice how the group= import feature is used to ensure the media, usage and notes are all added on the same row in the 
Supplementary table. 
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Reporting with supplementary media 
Supplementary media can be included in reports by adding the Supplementary_tab 
column to the list of fields on which to report. The Report Properties dialog below 
shows a report containing both the Multimedia and Supplementary media fields 
(Multimedia and Supplementary_tab respectively): 
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When the Supplementary_tab column is added to the list of fields on which to report, 
the Supplementary tab is added to the Report Properties dialog box. The 
Supplementary tab provides options that determine which supplementary media is 
included in the report: 
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The Multimedia set of options controls which Multimedia records attached to a record 
in a report are included in the report. Consider the Parties record below: 

 
A number of Multimedia records (images, video and audio) are attached to this 
Parties record. The Multimedia options determine which of these will be included in 
the report: 

 

Option Description 

Use first image only Only the Multimedia record for the first image is included in the 
report. 

Use all images The Multimedia records for all images are included in the report. 

Use first multimedia 
only 

Only the Multimedia record for the first attached record is 
included in the report. 

Use All multimedia The Multimedia records for all attached records are included in 
the report. 

For the Multimedia records specified by the Multimedia options, the Supplementary 
options then control which media listed in the Supplementary table will be included in 
the report. The options have the same meaning as in the table above, except that 
they apply to the Supplementary table in the Multimedia record. 

The File Delimiter option determines how the paths to the media included in the 
report are to be built: 
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Option Description 

/ Unix Use this option if the report is to be placed on a UNIX based 
computer. This is useful if the output is to be stored on the EMu 
server. 

\ Windows Use this option if the report is to be stored on a Windows based 
computer. In most cases this will be the option required as most 
reports are displayed on the user's computer. 

\\ Word Mail 
Merge 

Only use this option if the media is to be included in a Microsoft Word 
mail merge document. 

The report below shows a record with one Multimedia image and two associated 
supplementary images. In order to produce this output the following options were 
selected: 

Multimedia: Use first image only 

Supplementary: Use all images 

File Delimiter: \ Windows [This option is used as the report is 
viewed on the user's Windows computer.] 
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Supplementary media on the EMu 
server 

The supplementary media for a Multimedia record is stored in a directory called 
supplementary under the directory in which the master image is stored on the EMu 
server. The location of the master image is determined by the ServerMediaPath 
Registry entry (or in the absence of this entry, the ServerPath Registry entry). The 
Registry entry contains a list of paths to consult when locating multimedia on the 
EMu server. The first path in the Registry entry is used to store new multimedia, 
while all paths are searched to locate multimedia. 

There is a special case in which an exec entry may be used to interface between 
EMu and a third party imaging system (see EMu Help topic - Integrating 3rd party 
imaging systems for more details). In order to support supplementary media while 
still maintaining the same interface to third party systems, the filepath supplied to the 
get, save, ping and remove calls may now include the supplementary directory. For 
example, the file path passed to the ping call for a supplementary image called 
Image.jpg for the Multimedia record with IRN 4254 would be: 
4/254/supplementary/Image.jpg 

The list call should now return not only all media in the folder passed to it, but all 
media in the supplementary directory. For example, the call list 4/254 may result 
in the following response being returned: 
Status: success 
4/254/master.jpg 
4/254/master.thumbnail.jpg 
4/254/master.300x300.jpg 
4/254/supplementary/video.avi 
4/254/supplementary/image.tif   
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Supplementary media and IMu 
Supplementary media may be accessed from IMu via the virtual supplementary 
column in the Multimedia module. The PHP code below returns all supplementary 
media for the Multimedia record with irn 965: 
$module = new IMuModule('emultimedia', $session); 
$module->findKey(965); 
$columns = array 
( 
    'irn', 
    'supplementary' 
); 
$result = $module->fetch('start', 0, 1, $columns); 
$supplementary = $result->rows[0]['supplementary']; 

The data structure returned is an array in which each entry represents one row in the 
Supplementary table. For example: 
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Array 
( 
    [0] => Array 
        ( 
            [width] => 468 
            [usage] => Array 
                ( 
                    [0] => Web, 
                    [1] => Crop, 
                ) 
 
            [mimeFormat] => jpeg 
            [height] => 600 
            [size] => 31073 
            [index] => 4 
            [identifier] => spear head.jpg 
            [kind] => supplementary 
            [fileSize] => 31073 
            [notes] => A cropped image of the spear head. 
            [mimeType] => image 
            [md5Sum] => 5a7147c4f27ced997458b8171f2a44a6 
            [md5Checksum] => 5a7147c4f27ced997458b8171f2a44a6 
            [supplementary] => 0/007/supplementary/spear head.jpg 
        ) 
 
    [1] => Array 
        ( 
            [width] => 468 
            [usage] => Array 
                ( 
                    [0] => Web 
                ) 
 
            [mimeFormat] => jpeg 
            [height] => 600 
            [size] => 27584 
            [index] => 5 
            [identifier] => spear handle.jpg 
            [kind] => supplementary 
            [fileSize] => 27584 
            [notes] => A cropped image of the spear handle. 
            [mimeType] => image 
            [md5Sum] => ff57b2f343df44c4c8979cfd2d1f45d2 
            [md5Checksum] => ff57b2f343df44c4c8979cfd2d1f45d2 
            [supplementary] => 0/007/supplementary/spear handle.jpg 
        ) 
) 

To get a filtered list, a filter may be added to the column name. Filters are specified in 
parentheses after the column name. It's possible to filter on almost any value that 
comes back (with the exception of notes). So, if we only want supplementary media 
with images, the following PHP code segment could be used: 
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$columns = array 
( 
    'irn', 
    'supplementary(mimeType=image)' 
); 

The filter reduces the set of supplementary media to only those that are images. It's 
possible to specify multiple filters. For example, if you only want JPEG images, the 
following column construct could be used: 
supplementary(mimeType=image;mimeFormat=jpeg) 

or if you want all images except TIFFs: 
supplementary(mimeType=image;mimeFormat!=tiff) 

or if you want non-TIFF images with a width over 300 pixels: 
supplementary(mimeType=image;mimeFormat!=tiff;width>300) 

All of these filters simply discard supplementary entries from the result set which do 
not match the specified criteria.  

Two other operators are available: 

• @ 
• ^ 

If you want the single image which is closest to 300 pixels wide, use: 
supplementary(mimeType=image;width@300) 

This will return only one entry (at most), which is the image which is closest to 300 
pixels wide (may be bigger or smaller than 300).  

If you want to get the image that is closest to but bigger than 300 pixels, use: 
supplementary(mimeType=image;width^300) 

All these filters return information associated with the resource but not the resource 
itself. If you want the resource as well, the following construct is required: 
supplementary(mimeType=image;width^300){resource:include} 

This will return a structure that looks like: 
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Array 
( 
    [0] => Array 
        ( 
            [width] => 468 
            [usage] => Array 
                ( 
                    [0] => Web 
                ) 
 
            [mimeFormat] => jpeg 
            [height] => 600 
            [size] => 31073 
            [resource] => Array 
                ( 
                    [width] => 468 
                    [identifier] => spear head.jpg 
                    [file] => Resource id #12 
                    [mimeFormat] => jpeg 
                    [mimeType] => image 
                    [height] => 600 
                    [size] => 31073 
                ) 
 
            [index] => 4 
            [identifier] => spear head.jpg 
            [kind] => supplementary 
            [fileSize] => 31073 
            [notes] => A cropped image of the spear head. 
            [mimeType] => image 
            [md5Sum] => 5a7147c4f27ced997458b8171f2a44a6 
            [md5Checksum] => 5a7147c4f27ced997458b8171f2a44a6 
            [supplementary] => 0/007/supplementary/spear head.jpg 
        ) 
) 

Notice there is now a resource entry. This includes information about the resource 
and, most importantly, includes an open file handle to the resource contents (file 
attribute). 

If you want the resource to be reformatted in some way, you can specify the 
reformatting in the same way as you can for the existing resource column. For 
example, if you want the resource as a 200x200 gif, use: 
supplementary(mimeType=image;width^300){resource:include;format:gif;w
idth:200;height:200} 

This works just as before, but with the reformatted image as the resource: 
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Array 
( 
    [0] => Array 
        ( 
            [width] => 468 
            [usage] => Array 
                ( 
                    [0] => Web 
                ) 
 
            [mimeFormat] => jpeg 
            [height] => 600 
            [size] => 31073 
            [resource] => Array 
                ( 
                    [width] => 156 
                    [identifier] => spear head.gif 
                    [file] => Resource id #12 
                    [mimeFormat] => gif 
                    [mimeType] => image 
                    [height] => 200 
                    [size] => 18917 
                ) 
 
            [index] => 4 
            [identifier] => spear head.jpg 
            [kind] => supplementary 
            [fileSize] => 31073 
            [notes] => A cropped image of the spear head. 
            [mimeType] => image 
            [md5Sum] => 5a7147c4f27ced997458b8171f2a44a6 
            [md5Checksum] => 5a7147c4f27ced997458b8171f2a44a6 
            [supplementary] => 0/007/supplementary/spear head.jpg 
        ) 
) 
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