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Overview 
Users are given access to EMu by assigning them to a group. Each group has a set 
of permissions associated with it, and the user inherits the permissions of the 
group to which they have been assigned. Individual user based permissions may 
then be defined to override group based settings as required. The use of group 
based permissions means that it's not necessary to specify all the permissions on a 
per user basis, and only the difference between the group permissions and any user 
specific permissions need to be defined for any one user. 

Groups are generally based around real life roles, with each group reflecting the 
permissions required by all users who undertake the role. For example: 

• A Curatorial group might allow users to create new Catalogue records, but 
not to register new loans.  

• A Loans Officer group would have permission to create loans records, but not 
to create Catalogue records, and only to update the Condition Check and 
Locations fields for existing Catalogue records. 

Assigning a user to the Curatorial group, casts that user in the curatorial role. 

In general, the group system works well in EMu, except when a user performs 
more than one role within the institution. For example, a curator (group 
Curatorial) may also manage the loans for a small part of the collection (and so 
requires Loans Officer permissions). Until now, EMu provided two solutions to 
this dilemma: 

1. Create two usernames, assigning one to group Curatorial and the other to 
group Loans Officer. The user must then use the correct username when 
logging into EMu to perform the required role.  
Moving from one role to the other (e.g. a new loan arrives while the user is 
logged in as a curator), requires the user to log out of EMu and back in using 
the Loans Officer username. This could become tedious, and it requires that 
the user remembers two user names and two passwords. 

2. The second solution requires a new group to be created which is a merge of 
the permissions of the Curatorial and Loans Officer groups.  
The problem with this solution is that the combined privileges present a view 
of the world that is neither curatorial nor loan specific: it is possible to alter 
any field in a Catalogue record while raising a new loan. In other words, a 
new hybrid role is created (curator-loans office). 

In most cases the two original roles are sufficient and all that is required is a 
mechanism to switch between the two groups without having to log out and back 
in as another user. 

 Page 1 
 



Overview 
 

 

 

Page 2 

EMu 4.0.03 introduces multi-group support, which allows a single user to be 
registered in more than one group: 

• A user who is a member of more than one group can select the group name to 
use from the Login dialogue box when logging into EMu. 

• At any time it is possible to switch to another group without logging out and 
back in again. 

• When switching groups the user decides whether opened modules should 
remain open or whether they should be closed. 

• Any new modules opened will use the group permissions assigned to the 
group that the user switched to. 

By not closing open modules it is possible to have modules in different groups 
open at the same time. EMu ensures the correct group permissions are observed 
based on the group associated with the module. 

With multi-group support, a user is able to log in using one group, switch to 
another group while leaving existing modules open, perform operations in the new 
group and then switch back to the previous group, all without having to close any 
modules. A key feature of multi-group support is that it allows users to change 
roles without losing their current work position and then to return to that position 
at a later time. 

 Texpress 8.2.009 or later must be installed to provide the back-end security 
facilities for multi-group support. 
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Specifying a user's groups 
The EMu Group Registry entry defines which group a user is assigned to. It is 
consulted whenever a user logs in to EMu. The format of the Registry entry is: 

User|username|Group|groupname 

where groupname specifies the group to use when determining permissions. 

For example: 
User|badenov|Group|Curatorial 

specifies that user badenov is a member of the Curatorial group and has all the 
permissions assigned to that group. 

In order to provide multi-group support, the Group Registry entry has been 
extended to allow a semi-colon separated list of groups to be specified. The order 
of the groups is not important.  

For example: 
User|badenov|Group|Curatorial;Loans Officer 

specifies that user badenov is a member of both the Curatorial and Loans 
Officer groups. 

 Changes to the list of groups that a user has access to only come into effect 
when the user logs into EMu following any change to their Group Registry 
entry. If they are logged in when the change is made, they will need to log 
out and back in again in order to have access to the updated list of groups. 
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How to set an existing user's groups 
1. Log in to EMu as a System Administrator. 
2. In the Registry module, search for the user's Group Registry entry: 

i. Enter User into the Key 1 field. 
ii. Enter the user's username into Key 2. 
iii. Enter Group into Key 3. 
The matching Registry entry displays: 
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3. In the Value (Edit) field on the Registry tab, enter the name of all groups that 

the user is a member of. Each group should be placed on a separate line: 

 
4. Save the record. 

 As of EMu 4.0.03, security profiles are generated automatically after saving 
any user registration based Registry entries and it is no longer necessary to 
run Tools>Generate Record Security after changing user settings. 
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How to set a new user's groups 
1. Log in as a System Administrator. 
2. Add a new record in the Registry module: 

i. Enter User into the Key 1 field. 
ii. Enter the user's username into Key 2. 
iii. Enter Group into Key 3. 

3. In the Value (Edit) field on the Registry tab, enter the name of all groups that 
the user is a member of. Each group should be placed on a separate line: 

 
4. Save the record. 

 As of EMu 4.0.03, security profiles are generated automatically after saving 
any user registration based Registry entries and it is no longer necessary to 
run Tools>Generate Record Security after changing user settings. 
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Using multiple groups 
When a user has been registered to use multiple groups, the EMu Login dialogue 
box includes a drop list with the names of all available groups for the user.  

 The list of groups that displays is determined by the combination of 
username + service. A user can have the same username on multiple 
services, and in each service may be a member of different groups. 

The list is displayed only if the username supports more than one group.  

 A user must log in to EMu after changes have been made to their group 
membership before the (updated) list of groups will appear at login. Once a 
user has successfully logged in to EMu, the system Options may be used to 
switch to another group. See Switching groups via a module (page 10) for 
details. 
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Active group and module group 
EMu keeps track of the group selected when a user logs in to the system. This 
group is known as the active group and it is displayed in the title bar of the 
Command Centre. In this example, the active group is group Admin: 

 
Modules started by clicking a button in the Command Centre belong to the active 
group. The active group is also highlighted in the Login dialogue box the next 
time the user logs in to EMu. 

Modules are also associated with a group. When a module is invoked from the 
Command Centre its group is that of the Command Centre, namely the active 
group. If a module is created from within another module, by selecting 
Window>New>module, the module is associated with the same group as the 
module from which it was created. A module's group is displayed in the Status bar 
at the bottom right of the window. In this example the module's group is group 
Admin: 

 
A module cannot change group. Once it is created and associated with a group, it 
will remain in that group.  

It is possible to change the active group however. By doing so it is possible to 
create modules in different groups, thus allowing users to have multiple roles 
within the one EMu session. 
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Logging in to a group 
1. Start the EMu application. 

The Login dialogue box displays: 

 
2. Enter your username into the User field. 

If you are registered for more than one group with the current Service and you 
have logged in successfully previously, a Group drop list will be added to the 
Login dialogue box: 

 
3. Select a group from the Group drop list. 

4. Complete the rest of the log in details and select . 
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Switching groups via a module 
1. Select Tools>Options from the Menu bar of any open module. 

The Options dialogue box displays. 
2. Select the Security tab: 

 
The current active group is displayed in the Active Group drop list. 

3. Select a group from the Active Group drop list.  
The list only contains those groups the user is registered to use. 

4. Select . 
The Change Group dialogue box displays. 

 

 
 



Using multiple groups 
 

 

 
5. Select how any open modules should be handled when the active group is 

changed:  
• Close all modules 

All open modules will be closed. Only the Command Centre will remain 
open. 

• Close all modules in Group group 
All modules open in the active group (group) will be closed.  
This option is useful for closing all modules created since the last time 
the group was switched. For example, if you were asked a question that 
required switching groups to respond, this option will close the module(s) 
created to answer the question. All other open modules are left 
untouched. 

• Leave all modules open 
All modules currently open will remain open. Each module will remain in 
its current state and group. Once the switch is complete the modules may 
be used as required. Each open module will continue to provide 
functionality consistent with the module's group. 

6. Select . 
The active group will be switched. If a module scheduled for closure contains 
unsaved data, a message will display prompting the user to save the data 
before the module is terminated: 

 

Selecting  will abort the switching process. 
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Switching groups via the Command 
Centre 

1. Right click the Command Centre. 
A context menu displays: 

 
2. Select Options. 

The Options dialogue displays 
3. Continue from Step 2 above (page 10). 
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Registry cache 
The permissions of all groups and users in the system are specified in the EMu 
Registry and this information is stored on the EMu server. The Registry must be 
consulted each time the EMu client is required to determine whether a user is 
permitted to perform a given operation. As EMu provides a sophisticated security 
module the Registry may be accessed heavily for certain operations (starting a 
new module for example). In order to reduce the time required to query the 
Registry for permissions, the EMu client now contains a Registry cache. The 
cache is a mechanism that remembers what permissions have been asked for and 
the associated response. If the same question is asked again, the answer can be 
given without the need to access the EMu server. The Registry cache reduces 
traffic to the EMu server and provides a speed improvement in the EMu client. 

The one disadvantage of using a cache is that changes made to the EMu Registry 
by other users will not be picked up until either the cache is cleared (flushed) or 
you log out and log back in again. For example, if you are using EMu and you 
have been producing reports from the Parties module, and another user adds a new 
report to the Parties module, you will not see the report listed until you log out and 
log back in again, or until you flush the cache. 

In practice this tends not to be a serious issue and the speed gains more than 
outweigh any inconvenience. However, it may occasionally be necessary to clear 
the Registry cache: 
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Flushing the Registry cache 
1. Select Tools>Options from the Menu bar of any open module. 

The Options dialogue box displays. 
2. Select the General tab. 

 

3. Select . 

4. Select . 
A message displays once the cache is empty. 

 
Flushing the cache removes all Registry responses stored in the EMu client. Next 
time a Registry question is raised, the EMu client will contact the server for a 
response and the response will be added to the cache again. Until the cache 
becomes populated again a decrease in client performance may be experienced. 
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Enable / disable the Registry cache 
1. Select Tools>Options from the Menu bar in any open module. 

The Options dialogue box displays. 
2. Select the General tab: 

 
3. Tick / un-tick the Cache Registry Lookups checkbox to enable / disable the 

Registry cache. 

4. Select . 
If the Registry cache is disabled, it is flushed silently as its entries can no 
longer be used. 

Disabling the Registry cache will cause the EMu client to run significantly slower 
as all Registry queries must be answered by the server. The only useful purpose 
achieved by disabling the cache is to test the effect changing Registry entries has 
on a module, without the need to flush the Registry cache. In day to day use, the 
cache should be enabled. 
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Module caching 
Allowing users to switch between groups has implications for how EMu performs 
module caching.  

Module caching is a mechanism that allows modules to be hidden, rather than 
destroyed, when they are closed. If a new instance of the module is required, the 
hidden module may be used. Module caching provides significant speed 
improvements in situations in which modules are opened and closed on a regular 
basis. Module caching is configured via the Modules tab in the Options dialogue 
box: 

 
In the example above, one instance of the Catalogue module is created when EMu 
is invoked. When a Catalogue module is closed, a maximum of two instances are 
maintained in the module cache.  

With the introduction of support for multiple groups, the number of modules to 
cache now applies on a per group basis. Thus for the previous example, up to two 
instances of the Catalogue module will be cached per group. 

When switching groups, the Change Groups dialogue box allows the user to 
indicate not only how open modules should be handled, but also how cached 
modules are dealt with. For example, if you choose to Close all modules, then all 
open modules are closed and all cached modules are flushed. 
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Record Level Security 
Enabling users to be a member of multiple groups has implications for how record 
level security permissions are displayed in the EMu client. 
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Name selected in the 
Security field: 

Permissions displayed 

The person currently 
logged in to EMu 

The permissions displayed are the group permissions 
that apply to the module.  
A module joins a group in one of two ways:  

• If the module was created by clicking a button 
in the Command Centre, the module's group is 
the one that the user was logged in as when the 
module was opened. 

• If the module was created by selecting 
Window>New>module from a module Menu 
bar, the module's group is the same as the 
module from which it was created. 

The module's group is shown in the module's Status bar 
at the bottom right of the window (NGAConservator in 
the example above). 
For example, if a user is in two groups, Curatorial and 
Loans Officer, and the module was opened from the 
Command Centre when the user was logged in as a 
member of the Curatorial group, then the permissions 
displayed are those of the Curatorial group.  
This is as expected as the permissions reflect what 
operations (edit, delete) can be performed on the 
displayed record. 

Anyone else The permissions displayed are a merging of all the user's 
group permissions.  
For example, if a user is in two groups, Curatorial and 
Loans Officer, where group Curatorial has permission to 
delete the record, but group Loans Officer does not, then 
the permissions displayed will indicate that the user has 
delete permission.  
This is as expected as the user does have permission to 
delete the record, provided they log in or switch to 
group Curatorial. 

In the example above, user bern is logged in to EMu and the Parties module is in 
group NGAConservator (indicated in the Status bar). The record level permissions 
indicate that bern does not have permission to edit or delete the record, even 
though bern is also in group Admin, which does have edit permission. 
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Security profile extensions 
The EMu server security profiles have been extended to provide support for 
multiple groups per user. The profiles are maintained in XML format in a file 
named security in the database directory. Two new attributes have been added 
to the <user> tag to provide support for multiple groups: 

• level 
The level attribute defines a label for the user profile. By changing the value 
of the level label for a given user, a different set of security settings is 
enabled. The group name is used as the label value for EMu databases. To 
switch between groups the EMu client changes the level value to match the 
group of the module with focus, that is, the module with which the user is 
interacting. 

• default 
A "yes" value indicates this set of security settings should be used if the 
client has not set a level value. When the EMu client first connects, a level 
has not been set as the EMu Registry has not yet been consulted (a chicken 
and egg problem). Once the Registry can verify the log in group, the level is 
set to the supplied value. 

A user security profile is created for each group that a user is registered to use (via 
the User|username|Group Registry entry). If user badenov has the following 
Registry entry: 
User|badenov|Group|Curatorial;Loans Officer 

the following XML security segments are generated: 
<user name="badenov" level="Curatorial" default="yes"> 
 ...  
</user>  
<user name="badenov" level="Loans Officer"> 
 ...  
</user> 

The security profiles are built by the emusecurity command. This server side 
command consults the EMu Registry and builds suitable security profiles for all 
modules, for all users, for each group a user is in. The command is invoked 
automatically whenever a User|username|Group Registry entry is created, 
modified or deleted. emusecurity sets the default attribute to "yes" for the first 
group listed for each user. 

The security level is set via the seclevel database option. The value of the 
option is the security level to use. If the option has not been set or the value is 
empty, the security profile with the default="yes" attribute specified is used. For 
example, to load data into the parties module using group Curatorial the following 
commands could be used: 
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epartiesopts=seclevel=Curatorial  
export epartiesopts  
texload .... 

When using TexAPI, the seclevel is set via the TexOptionSet() call. For 
example, to change the security level to use group Curatorial for all EMu tables, 
the following call could be used: 
TexOptionSet(session, NULL, "seclevel", "Curatorial"); 

For perl based scripts, the OptionSet() call is used to alter the security level. For 
example, to change the security level to use group Curatorial for all EMu tables, 
the following call could be used: 
$session->OptionSet("", "seclevel", "Curatorial"); 

The seclevel option may be set on a per database basis or a system wide basis. 
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